Office 365 performance impact

Incident Report for m101

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 19:59 UTC

Investigating

We are currently experiencing delays in VM Management service operations due to a current issue on Microsoft’s Azure infrastructure. This impacts key operations which affects our backup infrastructure auto-scaling used for Office 365 backups.
As a result, performance for Office 365 backups may be degraded.
We are actively working with Microsoft and will share updates as they become available.
Thank you for your patience and understanding.
Posted Sep 10, 2025 - 13:56 UTC
This incident affected: Office 365 (East US2).